Page 1 of 2 12 LastLast
Results 1 to 10 of 20
Like Tree21Likes

Thread: What's causing this opposite effect on my two razors?

  1. #1
    Junior Member
    Join Date
    Sep 2017
    Posts
    9
    Thanked: 0

    Default What's causing this opposite effect on my two razors?

    So I just purchased a Brian Brown 5/8th (These are a quarter hollow I believe, and no smile on the blade), shaved with it, no pulling, went through the hair smooth, used some aftershave that has a touch of alcohol, no sensation. Grab the bottle of rubbing alcohol splash my face with a handful of liquid twice, no burning what so ever.

    My first razor when I first started with a straight was a Filarmonica 3rd Gen 7/8 (I think) has a bit of a smile to it, it pulls, but leaves a closer shave, and literally nicks every time at the beginning of every stroke if it is not done with a fluid sweep. It will also leave quite a few uncut hairs, even at the middle of the blade.

    The situation has got me confused because it essentially seems backwards.

  2. #2
    Senior Member
    Join Date
    May 2014
    Location
    Knoxville, TN
    Posts
    784
    Thanked: 230

    Default

    Greetings and welcome RapidTransit,

    Did the same person hone both of them at the same time?

    Cheers, Steve
    outback and Dieseld like this.

  3. #3
    Junior Member
    Join Date
    Sep 2017
    Posts
    9
    Thanked: 0

    Default

    Quote Originally Posted by Steve56 View Post
    Greetings and welcome RapidTransit,

    Did the same person hone both of them at the same time?

    Cheers, Steve
    The BBR came Ready to Shave and the Filarmonica was re-honed with Classic Shaving

  4. #4
    Senior Member blabbermouth RezDog's Avatar
    Join Date
    Feb 2013
    Location
    Haida Gwaii, British Columbia, Canada
    Posts
    9,144
    Thanked: 2751

    Default

    It does not sound like you Fili is shave ready. Is it fresh back from honing?
    Steve56 and outback like this.
    It's not what you know, it's who you take fishing!

  5. #5
    Junior Member
    Join Date
    Sep 2017
    Posts
    9
    Thanked: 0

    Default

    Quote Originally Posted by RezDog View Post
    It does not sound like you Fili is shave ready. Is it fresh back from honing?
    Nope, but it did hit the strop after it was returned from its honing, do you think it could be honed improperly?

  6. #6
    Senior Member Mrchick's Avatar
    Join Date
    Apr 2015
    Location
    Elk Grove, CA
    Posts
    1,723
    Thanked: 269

    Default

    I would suggest not stropping it after its next honing. If it shaves well, strop it for the second shave and try again. If it starts pulling, the issue may be stropping technique. I say this because I've been through this myself while learning to strop properly. Good luck.

  7. The Following 3 Users Say Thank You to Mrchick For This Useful Post:

    cudarunner (10-07-2017), Dieseld (10-07-2017), outback (10-07-2017)

  8. #7
    Senior Member
    Join Date
    Nov 2014
    Posts
    259
    Thanked: 48

    Default

    Partially not shaving hair and pulling? Something's up, try a good stropping and see if that brings your edge back up to par if not your edge sounds improperly honed, rolled, etc. etc.
    whatever it may be it's not in shaving condition

    As said, take a good look at your stropping technique
    Last edited by TristanLudlow; 10-07-2017 at 09:26 AM.

  9. #8
    Forum mogwai thebigspendur's Avatar
    Join Date
    May 2005
    Location
    New Mexico
    Posts
    27,508
    Thanked: 4361
    Blog Entries
    4

    Default

    It don't matter what a razor does, if it pulls in any way it's not shave ready period. The fluid sweep thing is operator error. Something you are doing if you stop and start a stroke. Why the other razor doesn't do is is either something about that razor or the way you are using it. Maybe size or weight or shape or the scales.
    Every day without fail one should consider himself as dead-Tsunetomo

  10. #9
    Senior Member blabbermouth outback's Avatar
    Join Date
    Mar 2015
    Location
    Akron, Ohio
    Posts
    6,358
    Thanked: 2318

    Default

    I'd have to say it sounds like the bevel was never joined properly
    sharptonn and Dieseld like this.
    Mike

  11. #10
    Senior Member
    Join Date
    May 2014
    Location
    Knoxville, TN
    Posts
    784
    Thanked: 230

    Default

    Ask Brian to hone the razor and tell you if there are issues with the Fili.

    Cheers, Steve
    sharptonn and outback like this.

  12. The Following User Says Thank You to Steve56 For This Useful Post:

    sharptonn (10-07-2017)

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •